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If you’re either a musician or someone 
who has the occasional musical idea to 
implement, there are a few great tools for 

the job on Fedora Linux. One of the most ex-
citing projects is called Qtractor.

There are, basically, two different ways 
to make music on computers: there is Audio 
(digital representations of sound waves) and 
there is MIDI (electronic pulses triggering a 
synthesizer or sampler). Qtractor handles 
both quite well, producing music using va-
rious forms of audio and MIDI sources.

Qtractor is available in the Fedora repo-
sitory. Along with Qtractor, you should install 
QJackCtl and QSynth. QJackCtl is an inter-
face for wiring sound from one application 
to another, while QSynth is an example of a 
good software synthesizer.

After these programs have been installed, 
launch Qtractor. It should start jackd automa-
tically – and you’re ready to make music.

There are three different ways to get 
sound into Qtractor; you can hook up a mi-
crophone and record realworld sounds, you 
can import pre-recorded loops, or you can 
generate sound using MIDI and a synthesi-
zer. Naturally, you can do any of these three 
for each track you create, thereby mixing 
MIDI data with audio tracks and loops until 
a full soundscape is achieved.

Recording Audio into Qtractor
To record sound from a microphone into 
Qtractor, first create an empty track. A 
“track” alots space where the sound may 
exist and be effected or adjusted. To create a 

new track, click the Add Track icon in 
Qtractor’s toolbar or go to the Track 
menu and select Add Track. This will 
bring up a dialog box where you may 
name the track and define whether 
it is a container for Audio or MIDI.

After the track has been added 
to the workspace, it must be armed 
for recording. Arming a track is 
marking that track as the ultimate 
destination for incoming audio. The 
button to arm a track is found un-
der the track’s name in the form of 
a button labeled with “R” just next 
to the “M” and “S” buttons. The 
“M” and “S” are “Mute” and “Solo”, 
respectively, where “Mute” silences 
the track and “Solo” silences all 
tracks but that track.

Now that the track is marked for 
recording, hit the Record button but-
ton in the top menu bar. Because Figure 1. Enable RPM Fusion for even more great apps!
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this is the first recording being made 
during this session, a dialog box will 
appear, asking for the filename and 
location of the data about to be re-
ceived. Define these carefully; good 
organization is a hallmark of good 
production, and where the raw data 
is stored now will make for easy bac-
kups or system migrations later.

Qtractor is using JACK for sound 
input and output, so the inputs 
defined by JACK are defining the 
source of the sound input. To see 
the current JACK connections, you 
make go to the View menu and se-
lect Connections. This will show you 
the JACK connection window, with 
input (including capture devices) on 
the left and writable targets on the 
right. Most likely, your system’s Cap-
ture device will be “plugged into” 
the Master Inputs of Qtractor. If this 
is not the case, then you may make 
that connection now.

With the track armed for recor-
ding, and recording mode enabled, 
click the Play button in the toolbar 
and recording will begin. Ideally, 
you should see sound waves being 
created in realtime as the micro-
phone captures whatever sound 
you are generating in the real world. 
If not, check your levels, your JACK 
connections, and if those appear 
to be in order, check alsamixer and 
whatever GUI frontend for Volume 
control your system uses (such as 
KMix on KDE).

Importing and Utilizing 
Pre-Recorded Loops
Whether you’re a professional musi-
cian or you’re completely tone-deaf, 
sometimes it is helpful to have pre-
recorded loops to help your com-
position along. These loops may 
be sound clips you yourself have 
created or they may be clips you’ve 
downloaded from http://www. 
freesound.org or loops you’ve got-
ten for free along with electronic 
music magazines or that you’ve 
purchased from loop collections. As 
long as they are in a standard audio 
format (ogg, wav, mp3, aiff, au, caf, 
paf, and many more), they can be 
imported and used in your project.

On the right of the Qtractor win-
dow there is a Files panel; thus far an 

audio file will be visible, which repre-
sents the clip recorded into the first 
track. To bring in new files, right-click 
in the Files panel and select Add Fi-
les. Note that there are tabs at the 
bottom of this panel; one for Audio 
and one for MIDI. You cannot import 
Audio tracks into the MIDI tab, so be 
sure that the Audio tab is selected.

Select an audio file to add to 
your arsenal and they will be listed 
in the Files panel. You may audition 
them by clicking on them; stop them 
from playing with the Play button on 
the lower right of the panel. Once 
you’ve decided which loop to add to 
your project, drag and drop it from 
the Files panel into the empty space 
of your workspace. It will automati-
cally add a new track for itself, com-
plete with an appropriate name.

If this is a short loop, it probably 
needs to be repeated a certain num-
ber of times. To loop the clip, select 
the clip and right-click it, selecting 
Copy. Then right-click the space adja-
cent to that clip and select Paste Re-
peat. A dialogue box appears, asking 

how many times you wish it to repeat. 
Give it a number, click OK, and then 
place the string of clips where you 
wish them to continue looping.

Since the art of looping relies on 
the lack of interruption of the clips, 
it often is helpful to fine-tune the 
Snap option of your cursor. By ena-
bling snapping, you force your cur-
sor to constrain its movements to 
anything from being on the beat, or 
within one-eighth note of the beat, 
or one-sixteenth, and so on. Since 
loops are delivered as whole bars, 
constraining the snapping to the 
beat is a good idea. To do this, go 
to the View menu, to the Snap sub-
menu, and select Beat.

MIDI in Qtractor
Qtractor’s MIDI features are quite ro-
bust and, due to its JACK awareness, 
allows the use of a wide variety of 
MIDI soft synths and applications. 
This means that you can either use 
soft synth plugins or stand-alone 
soft synths with Qtractor, making it 
a powerful MIDI sequencer.

Figure 3. Mixing Audio and MIDI together to make hardcore jams  
in Qtractor

Figure 2. Jack, the heartbeat of your sound production 
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Soft Synth Plugins
Qtractor supports DSSI, LADSPA, 
VST, and LV2 (in svn) plugins, thereby 
providing a full spectrum of software 
synthesizers, samplers, and effects 
all from within one workspace. Many 
of the prominent Linux native synths 
and effects are available via your 
distribution’s repositories, others 
can be found online.

Download and install the plugins 
you wish to use in Qtractor and then 
switch to Qtractor to define where 
they are found on your system. Do 
this via the View menu −> Options. 
In the Options window, navigate to 
the Plugins tab; on the left of this 
tab is a dropdown menu of different 
kinds of plugins (DSSI, LADSPA, 
VST) and on the left are buttons to 
browse your system in order to defi-
ne for Qtractor where it should look 
to find the plugins you’ve installed. 
Depending on your distribution, the 
location may vary, but typically the 
plugin files (.so files) will be located 
in /usr/lib/ or /usr/local/lib/.

Once you’re pointed Qtractor 
to the location of your plugins, you 
must make a track for whatever 
MIDI data you wish to create. This is 
done with the Add Track button on 
the toolbar, or via the Track menu. In 
the Track dialog box, select to make 
the track a MIDI track and leave the 
remaining defaults as they are.

Now that you have a MIDI track 
in your project, you may assign a 
plugin to it so that the MIDI data 
you create will trigger sounds. Right-
click on the name of the MIDI track, 
and select Track Properties. This 
opens up the Properties window; 
click on the Plugins tab at the top, 
and then on the Add button within 
this tab area.

A list of all of your installed plu-
gins appears; select a sound gene-
rator you wish to use to generate 
sound, and click OK. Now the synth 
of your choice is assigned to that 
track. Depending on the synth, the-
re may be a new window visible with 
an Edit or Parameters button, which 

will give you greater control over 
what sound bank or waveform that 
synth will be using. A good synth 
to start with is WhySynth, a DSSI 
plugin with hundreds of pre-made 
sounds to choose from.

To create new MIDI data, click 
the New Clip button on the toolbar 
or go to the Edit menu, select the 
Clip submenu, and select New. The 
MIDI Editor (sometimes called a 
“piano roll”) window appears, with 
the beats and bars counted along 
the top and the keys of a piano 
along the left border. Notes are 
drawn with the Pencil tool, defining 
what note will play upon what beat. 
This is known as sequencing, and 
there are many ways to do it. You 
might wish to plug in a USB MIDI 
keyboard, hit record, and actually 
play MIDI data into Qtractor. Or you 
may wish to simply point and click, 
drawing notes where you need them 
to play in your composition. There is 
no right or wrong way to do it, and 
either way allows you to return later 
and modify your work.

When you have finished sequen-
cing your MIDI notes, close the MIDI 
editor window. It will prompt you to 
save the data, and then the data ap-
pears in your MIDI track. Playing your 
composition back will allow you to hear 
all of your data, be it MIDI or audio.

Stand-Alone Soft Synths
“JACK is a sound server” declares 
the FAQ of JACK’s official website – 
a definition well beyond the compre-
hension of most average musicians. 
In simpler terms, it is a connection 
between two otherwise completely 
unrelated audio applications. 

It is because of JACK that Qtrac-
tor can actually drive a stand-alone 
software synth. For this to work, 
you need to download and install 
a stand-alone synth that is JACK 
aware. Qsynth is a popular frontend 
to the very flexible fluidsynth; down-
load it from your repository or from 
the project’s site, and then hunt 
down some good soundfonts and 
load them into Qsynth.

With Qtractor (and by default, 
jackd) running, launch Qsynth. It will 
plug itself into JACK but you should 
verify that its MIDI settings are cor-

Figure 4. Editing audio loops in Qtractor

Figure 5. Soft Synths assigned to MIDI tracks in Qtractor’s Mix window
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rect by clicking the Setup button 
and navigating to the MIDI tab. Ena-
ble MIDI input and select your MIDI 
driver, which is typically alsa_seq. 
If this fails, you may do a lsmod to 
view what MIDI-related modules are 
active, or simply try different dri-
vers (jack, alsa_raw, oss) until the 
MIDI signal is received properly by 
Qsynth. You may also launch QJack
Ctl and check to ensure that ALSA 
Sequencer Support is turned on in 
the Setup −> Misc tab.

You may now create a new track 
in Qtractor. In the New Track dialo-
gue box, make the track MIDI and 
click OK. After the empty track ap-
pears in the Qtractor workspace, 
right click on its name and select 
Outputs. This brings up the connec-
tion window’s MIDI tab, where you 
should route Master (on the left) to 
the fluidsynth input (on the right). 
Now you have connected that track, 
on MIDI channel 1, to Qsynth/fluid-
synth and any data you place in that 
track will be played by Qsynth.

Since the stand-alone synth oc-
curs outside of Qtractor’s interface, 
any changes you wish to make to 
the sound being generated by that 
synth will be done, unlike with DSSI 
or VST plugins, external of Qtrac-
tor. To do this, simply switch to the 
synth and change what bank and 
patch you are using from within its 
interface.

Bounce Your Track
In order to distribute your completed 
track as a self-contained audio file, 
such as a .wav or .ogg file, the track 
must be “bounced” (that is, played 
back and recorded to a file).

The easiest way to do this is to 
create a new Audio track, name it 
“Bounce”, and arm it for recording. 
Then open your Connections win-
dow to the Audio tab. If you used 
audio tracks or synth plugins, pipe 
the Master Out of Qtractor to the 
Master In of Qtractor. If you used 
a stand-alone synth, then pipe the 
audio out of that synth back to the 
Master In of Qtractor.

Make sure that your playhead is 
at the beginning of the composition. 
Click the Record button of Qtractor in 
the main toolbar, and then Play; your 

work will be played back in realtime 
and recorded onto the Bounce track. 
When finished, stop the playback.

You may export the Bounce 
track by clicking its “S” button (for 
Solo) and clicking on the Track 
menu −> Export −> Audio. Working 

and Exporting in .wav or some other 
uncompressed format is generally 
a good idea; from this gold master, 
any number of compressed file for-
mats can be generated, using sox 
or oggenc or LAME or similar appli-
cations.  

Figure 6. The MIDI “Piano Roll”

Figure 8. Qtractor in full swing on Fedora 15

Figure 7. The Qsynth Software Synth


